Windows Installer Problem Error 1325 Documents is not a valid short file name

Windows Installer Problem Error 1325 Documents is not a valid short file name

Bei einem Benutzer, der sein Homelaufwerk auf einem Netzlaufwerk hatte und die Dokumentenpfade angepasst hatte auf diese Ordner per GPO hatte das Problem, das er keine Software installieren konnte – die Installation brach immer mit dem Fehler Error 1325 Documents is not a valid short file name ab.

Ich habe die Rechte vom Rootordner geprüft und der User hatte keine Leserechte des Rootordners. Nachdem ich den User (bzw. Gruppe Domänen-Benutzer) Leserechte gab auf dem Ordner (Achtung: Bitte Vererbung beachten!)  und der User sich neu anmeldete, war das Problem behoben und der Installer lief ohne Probleme durch.

Laut Recherche lag die Vermutung nahe, das der Installer versucht zu lesen, wieviel Platz auf dem Laufwerk ist – was jedoch fehl schlug, da er keine Leserechte auf den Rootordner hatte.


ESXI Fehler: Arbeitsspeichergrenzwert akzeptiert nicht den negativen Wert

Der ESXI 6.5 hat nur noch ein Webinterface – so das man nicht mehr auf einem FAT Client ausweichen kann, wenn man Probleme mit der Webgui haben sollte.

Leider kommt es oft vor, das wenn man eine VM Konfiguriert einem der folgende Fehler die Konfiguration verweigert:

Arbeitsspeichergrenzwert akzeptiert nicht den negativen Wert

Ich habe dies oft wenn ich den Firefox verwende und eine VM Wiedergabe und dann über diese dann die Einstellungen öffnen möchte.

Bisher konnte ich das Problem immer lösen, wenn ich folgendes ausführte – manachmal half das direkt, manchmal muss ich jedoch auch den nächsten Schritt ausführen:

  • VM Fenster und Eigenschaften schließen, öffnen der Eigenschaften durch rechte Maustaste auf den VM Namen.
  • Aktualisieren des Browser inklusive neuanmelden – dabei jedoch achten, das man die Übersicht aufruft und nicht wieder direkt die VM.
  • Als letzten Weg hatte ich dann eben eifach einen anderen Browser zu verwenden (z.B. Chrome oder Edge).

Exchange 2016: Emails gehen nicht raus

Bei einem frisch installierten Exchange Server hatte ich das Problem das Mails nicht raus gingen. Weder direkt per MX noch über Relay.

Der Exchange sollte Mails an ein Mailrelay auf einer internen Sophos übergeben, die Mails gingen weder rein noch raus.

Wurden Mails im OWA versendet, lagen diese in Entwürfe und gaben die Meldung „Es ist ein Fehler aufgetreten“ und im Outlook blieben die Mails einfach im Postausgang liegen.

Testweise habe ich dann mit Telnet eine Mail an den Exchange gesendet um zu schauen ob ich einen Fehler sehe – und siehe da, mir wurde gemeldet: „4.5.1 Temporary Server Error PRX2“.

Bei einer Recherche fand ich dazu 2 Möglichkeiten:

Zum einen sollte in den Servereigenschaften (ECP) der DNS Server überschrieben werden, da es Probleme geben kann wenn ein interner (z.B. DC) und ein externer DNS (z.B. Provider DNS oder Firewall/Router mit Forwarder nach außen) verwendet werden in den Servernetzwerkeinstellungen. Zusätzlich könnte man auch in der Hosts-Datei alle internen Server mit IP, Hostname und FQDN aufnehmen.

Zum anderen kann es zu Problemen kommen wenn mehrere Connectoren den selbern Port verwenden (auch wenn die unterschiedliche Quelladressen verwenden). Da der SMTP und ein Relayserver auf dem selben Port lagen, habe ich kurzerhand den Relay auf die Sophos umverlegt.

Nach einem Serverneustart funktionierte nun wieder alles.

Quellen:

http://www.servolutions.de/support/articles/temporaryservererror2013.htm

https://www.servolutions.de/support/installexchg2013.htm#section3