Exchange 2010: Leere Seite oder Fehlermeldung nach Anmelden am OWA

Exchange 2010: Leere Seite oder Fehlermeldung nach Anmelden am OWA

Sollte nach einem Anmelden ans OWA nur eine Leere Seite erscheinen oder eine Seite mit dem Hinweis das die Seite nicht geladen werden konnte so sollte man wie folgt vorgehen:

  • Prüfen ob alle Exchange Updates installiert sind (Stand 11.12.15 SP3 RU 11), wenn nicht diese installieren
  • Dann Updatecas.ps1 ausführen (C:\Programme\Microsoft\Exchange Server\V14\Bin in Exchange Powershell, beim Starten aus dem selben Verzeichnis noch .\ vor dem  Befehl setzen)
  • Nach Erfolg noch einen IISReset (CMD mit Administratorrechten)

 


Exchange 2010/2013/2016 ohne SAN Zertifikat betreiben

Sollte man von einem SAN Zertifikat umsteigen auf ein herkömmliches Zertifikat, so muss man auch noch einige Einstellungen im Exchange vornehmen, damit keine Fehlermeldungen mehr erscheinen beim öffnen von Outlook usw.

Vorbereitungen:

  • In der ECP die externe Adresse unter Nachrichtenfluss > Akzeptierte Domänen einrichten.
  • Danach in der ECP unter Nachrichtenfluss > E-Mail-Adressrichtlinie die Default Policy bearbeiten mit der externen Adresse und Anwenden.
  • Im Internen DNS (AD-DNS und DNS für die echte Emailadresse) sowie im Externen DNS folgendes einrichten:
    • Hosteintrag auf dem das Zertifikat läuft
    • CNAME von autodiscover auf die Zertifikatsadresse.
    • Servicerecord erstellen mit den folgenden Werten:

Service: _autodiscover
Protokoll: _tcp
Priorität: 0
Gewichtung: 0
Port: 443
Host: Adresse des Hostes auf dem das Zertifikat läuft

Danach müssen in der Exchange Management Shell folgende Änderungen vorgenommen werden:

Set-ClientAccessServer -Identity servername -AutoDiscoverServiceInternalUri “https://exchange.domain.de/Autodiscover/Autodiscover.xml”

Set-AutodiscoverVirtualDirectory -Identity “servername\Autodiscover (Default Web Site)” -InternalUrl “https://exchange.domain.de/Autodiscover/Autodiscover.xml” -ExternalUrl “https://exchange.domain.de/Autodiscover/Autodiscover.xml”

Set-WebServicesVirtualDirectory -Identity “servername\EWS (Default Web Site)” -InternalUrl “https://exchange.domain.de/EWS/Exchange.asmx” -ExternalUrl “https://exchange.domain.de/EWS/Exchange.asmx”

Set-OWAVirtualDirectory -Identity “servername\OWA (Default Web Site)” -InternalUrl “https://exchange.domain.de/owa” -ExternalUrl “https://exchange.domain.de/owa”
Set-ECPVirtualDirectory -Identity “servername\ECP (Default Web Site)” -InternalUrl “https://exchange.domain.de/ecp” -ExternalUrl “https://exchange.domain.de/ecp”
Set-ActiveSyncVirtualDirectory -Identity “servername\Microsoft-Server-ActiveSync (Default Web Site)” -InternalUrl “https://exchange.domain.de/Microsoft-Server-Activesync” -ExternalUrl “https://exchange.domain.de/Microsoft-Server-Activesync”
Set-MapiVirtualDirectory -Identity „servername\mapi (Default Web Site)“ -InternalUrl https://exchange.domain.de/mapi -ExternalUrl https://exchange.domain.de/mapi -IISAuthenticationMethods NegotiateSet-OABVirtualDirectory -Identity “servername\OAB (Default Web Site)” -InternalUrl “https://exchange.domain.de/OAB” -ExternalUrl “https://exchange.domain.de/OAB”
Enable-OutlookAnywhere -Server servername -ExternalHostname “exchange.domain.de” -ClientAuthenticationMethod “Basic”-SSLOffloading:$False

Weitere Infos:


Exchange 2010 (SP1) – Postfach sofort löschen

Auf dem Exchangeserver das entsprechende Postfach löschen (Deaktivieren = nur Postfach entfernen, Löschen = Postfach UND User löschen).

Danach wird das Postfach nicht umgehend gelöscht, sondern wird erst mal nur zum löschen markiert.

Soll das umgehend gelöscht werden, so benötigt man die GUID des Postfaches, diese bekommt man mit

get-mailboxdatabase | get-mailboxstatistics | Where{ $_.DisconnectDate -ne $null } |fl displayName,Identity,disconnectdate,database

angezeigt. Mit der GUID kann man dann mit dem folgenden Befehl das Postfach direkt löschen:

Remove-StoreMailbox -database “MBDB01″ -Identity “bcfd82dc-0b14-4ee3-aceb-f369159ddbc1″ -MailboxState Disabled

Sollte das Postfach noch gelöscht, sondern noch zum Beispiel von einer Verschiebeaktion noch vorhanden sind, so kann man das sofortige löschen  wie folgt anstoßen lassen:

Remove-StoreMailbox -database “MBDB01″ -Identity “bcfd82dc-0b14-4ee3-aceb-f369159ddbc1″ -MailboxState SoftDelete


Exchange 2010 Mails bleiben in Entwürfe hängen

Wenn gesendet mails nicht rausgehen, sondern in den Entwürfen hängen bleiben, dann kann das daran liegen, das die Transportwarteschlange beschädigt ist.

Dann kann es hilfreich sein, diese neu zu erstellen. Wie dies geht ist hier beschrieben: http://www.cgoosen.com/2010/09/exchange-2010-moving-mail-queue/

Sind jedoch Transport und Informationsspeicher auf getrennten Systemen – so ist die Warteschlange nicht auf dem Informationsspeicherserver zu finden.