OpenVPN / Sophos SSL VPN Client: Windows Rechner als Softwarerouter verwenden

OpenVPN / Sophos SSL VPN Client: Windows Rechner als Softwarerouter verwenden

Achtung: Seit dem 23.1.2019 habe ich auch einen Artikel der erklärt, wie man einen Raspberry Pi verwenden kann. Diese Lösung wäre zu bevorzugen!

Dieser Tip funktioniert zwar grundsätzlich, ist aber weit entfernt davon als stabil zu gelten – womöglich kann er dazu dienen eine kurze Zeit als Notlösung zu fungieren.

Stellen Sie auf dem Rechner im BIOS/UEFI ein, das der Rechner immer an bleibt und nach einem Stromausfall wieder hochfährt.

Stellen Sie im Windows in den Energieoptionen ein, das der Rechner nicht ausschaltet (Festplatte und Monitor können jedoch ausgehen). Es muss niemand am Rechner angemeldet sein, nachdem alles eingerichtet wurde! Es reicht wenn er hochfährt.

Melden Sie sich an Windows mit Adminrechten an und geben Sie dem Rechner eine Feste IP, sowie alle benötigten weiteren Parameter wie DNS und Gateway.

Installieren Sie den aktuellsten Open VPN oder Sophos VPN Client und richten Sie die SSL Verbindung ein (am besten mit rechter Maustaste und „Als Administrator ausführen“) und testen Sie die Verbindung.

Sollte diese funktionieren, gehen Sie bitte in das Config Verzeichnis des VPN Clients (z.B. C:\Program Files (x86)\Sophos\Sophos SSL VPN Client\config) und erstellen sie eine Datei mit dem Namen password.txt, tragen sie in der ersten Zeile den Benutzernamen und in der zweiten Zeile das Kennwort ein.

Öffnen Sie die entsprechende Config-Datei und tragen Sie nach auth-user-pass ein Leerzeichen und dann password.txt ein:

auth-user-pass password.txt

Prüfen Sie nun ob Sie die Verbindung ohne Zugangsdaten aufbauen können.

Klicken Sie nun auf Start und tippen Sie services.msc und machen ein Doppelklick auf OpenVPN Service und stellen Sie die Startart auf Automatisch.

Wenn Sie den Rechner neustarten und sich anmelden, sollten sie nach ein paar Sekunden Adressen aus dem entfernten VPN anpingen können (ohne das der VPN Client eine Verbindung anzeigt). Es sollte jedoch die Netzwerkschnittstelle des VPN Clients im Netzwerk- und Freigabecenter aktiv sein (kein rotes X).

Sollte nun soweit alles funktionieren, gehen Sie bitte mit der rechten Maustaste auf die Verbindung in die Eigenschaften auf dem Tab Freigabe (sollte der nicht vorhanden sein, deinstallieren Sie bitte den alten VPN Client und installieren eine aktuelle Version mit Adminrechten).

Windows wird nun eine Meldung ausgeben, das von der Netzwerkschnittstelle die IP Adresse verändert wird auf 192.168.137.1 – stellen Sie die Netzwerkeinstellungen wieder zurück auf die richtigen Werte. Nach ein paar Sekunden sollten wieder entferne Ressourcen anzupingen sein.

Damit nun die anderen Rechner auch das entsprechende Netz finden, müssen Sie eine Route erstellen auf das entfernte Netz, damit sie das nicht an jedem Rechner machen müssen, machen Sie das am besten auf den vorhandenen Router, der die Internetverbindung herstellt – z.B. bei einer Fritzbox unter Heimnetz > Netzwerk > Netzwerkeinstellungen > IPv4 Routen:

Bekannte Probleme:

Nach einem Neustart funktioniert die Verbindung zwar an dem Rechner wo das VPN Installiert ist, jedoch nicht mehr bei den anderen Geräten im Netzwerk:

Hier muss einmal wieder der Hacken bei „Internetverbindung freigeben“ bei der VPN Netzwerkschnittstelle entfernt werden – da dabei Windows auch die IP bei der LAN Verbindung zurücksetzt auf 192.168.137.1, muss hier wieder alles die zuvor konfigurierte Adresse zurückgesetzt werden. Nach ein paar Sekunden ist die Verbindung durch den VPN Dienst wieder neugestartet und sollte wieder funktionieren.

Alle Geräte im Netzwerk können auf das Remotenetzwerk zugreifen, jedoch das Remotenetzwerk nicht auf die lokalen Geräte:

Dies wird auch leider nicht funktionieren, da alle Geräte hinter der Adresse des einzelnen VPN Rechners per NAT (Network Adress Translation) versteckt sind und nicht erreichbar sind. Hier würde eine Lösung benötigt, die das gesamte Netz anbindet (z.B. ein Hardwarerouter auf Raspi-Basis). Evtl. kommt hierzu noch ein entsprechender Beitrag.


Windows Installer Problem Error 1325 Documents is not a valid short file name

Bei einem Benutzer, der sein Homelaufwerk auf einem Netzlaufwerk hatte und die Dokumentenpfade angepasst hatte auf diese Ordner per GPO hatte das Problem, das er keine Software installieren konnte – die Installation brach immer mit dem Fehler Error 1325 Documents is not a valid short file name ab.

Ich habe die Rechte vom Rootordner geprüft und der User hatte keine Leserechte des Rootordners. Nachdem ich den User (bzw. Gruppe Domänen-Benutzer) Leserechte gab auf dem Ordner (Achtung: Bitte Vererbung beachten!)  und der User sich neu anmeldete, war das Problem behoben und der Installer lief ohne Probleme durch.

Laut Recherche lag die Vermutung nahe, das der Installer versucht zu lesen, wieviel Platz auf dem Laufwerk ist – was jedoch fehl schlug, da er keine Leserechte auf den Rootordner hatte.


Windows Server 2008: Sicherung auf NAS (SMB Netzwerkfreigabe)

Windows Server 2008 wird leider noch bei einigen Kunden eingesetzt obwohl er EOL (End of Life) ist.

Dieser bietet zwar die Windows Sicherung an, kann jedoch mit der GUI nicht auf einem Netzlaufwerk (NAS / SMB).

Mit der GUI kann man auf USB, Firewire oder iSCSI Laufwerke sichern.

Die GUI kann im Servermanager als Feature installiert werden.

Wenn die Sicherung auf einem NAS benötigt wird, dann kann man dies nicht mit der GUI, jedoch mit den Befehlszeilen Tools realisieren – diese können ebenfalls als Feature installiert werden.

Es kann ein Sicherungsskript erstellt werden welches mit dem Aufgabenplaner entsprechend ausgeführt wird:

@ECHO OFF
REM zuerst Backup Verzeichnis der NAS mappen und alte Verzeichnisse löschen
REM Anzahl = Anzahl der Verzeichnisse, die nicht gelöscht werden
REM fuer Aktivierung ECHO entfernen, ansonsten nur Anzeige
NET USE X: \\IP-NAS\FREIGABE /user:USER PASS
set Loesch=X:\
set Anzahl=5
for /f "skip=%Anzahl%" %%i in ('dir /AD /B /O-D %Loesch%') do echo rd /s /q "%Loesch%\%%i"

REM neues Backupverzeichnis nach Datum erstellen
set jahr=%date:~-4%
set monat=%date:~-7,2%
set tag=%date:~-10,2%

set newfolder=%jahr%-%monat%-%tag%
mkdir X:\%newfolder%

REM Backup durchführen
REM wbadmin Befehlszeile einfügen, z.B
wbadmin start backup -allCritical -include:C: -backupTarget:\\IP-NAS\FREIGABE\%newfolder% -vssfull -quiet

REM Variablen loeschen
net use X: /delete /yes > NUL
set Loesch=
set Anzahl=
set jahr=
set monat=
set tag=
set newfolder=
EXIT

Quelle: https://www.mcseboard.de/topic/193805-sbs2011-skript-backup-auf-nas/?do=findComment&comment=1200963

Weiterführende Informationen zu WBAdmin: https://www.it-zeugs.de/wbadmin.html


Windows 10 System richtig einrichten

Windows 10 ist mittlerweile schon sehr komfortabel geworden – jedoch sollten so einige Dinge noch nachgestellt bzw. nachinstalliert werden.

Sicherheitseinstellungen:

Bitlocker Festplatte verschlüsseln:
Da ich auf meinem Laptop einige Daten habe, welche ich nicht in andere Hände wissen möchte, habe ich die Bitlocker Festplattenverschlüsselung aktiviert. Dazu einfach unten in der Adresszeile Bitlocker eingeben und Bitlocker entsprechend einrichten. Achten sie bitte unbedingt darauf, das sie den Schlüssel zur Entschlüsselung sichern und nicht auf dem Gerät lassen – alternativ können Sie diesen auch im Microsoft Account hinterlegen. Sollten Sie dies machen, sollten Sie entsprechend Hoch die Sicherheit des Accountes halten – ich nutze z.B. die 2 Faktor Authentifizierung, diese wird mit einer kostenlosen App auf dem Smartphone sichergestellt.

Computerschutz:
In Windows 7/8/8.1 war direkt der Computerschutz aktiv, welcher vor Updates usw. immer vorher eine Snapshot (VSS Schattenkopie) erstellte – welcher mir schon so einige geholfen hatte. Leider ist in einer frischen Windows 10 Installation diese Funktion deaktiviert. Zum aktivieren gehen Sie bitte mit der rechten Maustaste auf Dieser PC > rechte Maustaste > Eigenschaften > Computerschutz und aktivieren Sie dort den Computerschutz. 5% sollte ein guter Wert sein.

Defender Schutz vor Verschlüsselung:
Im Creators Update ist ein interessantes Feature hinzugekommen – dies schützt vor Verschlüsselungstrojanern. Um dies zu aktivieren öffnen Sie das Defender Security Center und gehen dort auf VIren und Bedrohungsschutz > Einstellungen für Viren und Bedrohungsschutz > Aktivieren sie nun den Punkt Überwachter Ordnerzugriff.

Jedoch, wo Licht ist – ist auch Schatten, es wird einigen Programmen der Zugriff auf die eigenen Dateien verboten und diese müssen nach und nach Freigeben werden. Weiterhin sollte man auch bedenken, das meistens Office der Zugriff auf die eigenen Dateien erlaubt ist – sollte man sich nun einen Verschlüsselungstrojaner aus einem Officedokument einfangen, hat dieses weiterhin Zugriff auf die Dokumente und kann diese verschlüsseln.

Der wichtigste Schutz ist immer noch die Datensicherung – ich selber nutze Acronis True Image 2018. Oft bekommt man Updateangebote für ca. 40€ für 3 Lizenzen. Acronis hat ebenfalls einen Schutz vor Verschlüsselung und sichert auch die Daten. Ein interessantes Feature ist der Try adn Decade Modus – hier kann man Einstellungen und Software testen ohne diese direkt in das System zu integrieren – bedeutet das wenn der Schutz an ist, man Software installieren und einrichten kann. Ist die Software in Ordnung, kann man den aktuellen Stand sichern oder eben verwerfen wenn diese nicht in Ordnung ist.

UAC auf sehr Hoch stellen:
Die UAC ist ein guter Schutz, jedoch richtig sicher ist sie nur in der Einstellung Hoher Schutz.

Zusatzanwendungen:

Windows hat zwar schon jede Menge Programme an Board, jedoch installiere ich noch die folgenden um meine Ausstattung zu komplettieren (bitte achten Sie darauf, das nur die benötigte Software installiert wird – einige Programme versuchen weitere Software mitzuinstallieren, entfernen Sie die entsprechenden Hacken):

Da ich noch entsprechende Abos habe noch:

Dazu stelle ich noch folgende Programme als Standardprogramme ein:

  • Email: Outlook
  • Internet: Chrome
  • PDF: Acrobat Reader
Hinweis: Diese Empfehlungen basieren auf meinen Erfahrungen, diese Links werden nicht gesponsert oder in irgend einer Form vergütet. Sollten Sie bessere Programme kennen, dann würde ich mich über entsprechendes Feedback freuen.

ESXI/Veeam: Failed to create Snapshot

Um Linuxserver sowie in virtuellen als auch in physischen Umgebungen zu sichern bietet Veeam den kostenlosen Backup Agent für Windows sowie für Linux an.

Diesen hatte ich auf einen virtuellen Debian Server eingesetzt – hatte jedoch das Problem, das die Sicherungen nicht liefen, da anscheinend der Snapshot nicht erstellt wurde.

Der Fehler lautete:

[18.01.2018 15:37:38] <140310290929408> lpbcore| WARN|Failed to get used space on device [sda5].
[18.01.2018 15:37:38] <140310290929408> lpbcore|       Partition sda5, size: 4393533440, used: 4393533440.
[18.01.2018 15:37:38] <140310290929408> lpbcore|     Used space: 59995000832.
[18.01.2018 15:37:38] <140310290929408> lpbcore|     Overall data size used: 59995000832.
[18.01.2018 15:37:38] <140310290929408> lpbcore|   Taking snapshot.
[18.01.2018 15:37:38] <140310290929408> vmb    |     [SessionLog][processing] Creating volume snapshot.
[18.01.2018 15:37:38] <140310290929408> lpbcore|     Adding disk backup object into snapshot set. Disk: [sda].
[18.01.2018 15:37:38] <140310290929408> lpbcore|       Request to snapshot device: [8:1].
[18.01.2018 15:37:38] <140310290929408> lpbcore|       Request to stop tracking device: [8:0].
[18.01.2018 15:37:38] <140310290929408> lpbcore| WARN|Method invocation was not finalized. Method id [1]. Class: [lpbcorelib::interaction::ISnapshotOperation]
[18.01.2018 15:37:38] <140310290929408> lpbcore| ERR |Child execution has failed. Exit code: [1].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to execute [modprobe].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to finish snapshot creation process.
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to execute method [1] for class [lpbcorelib::interaction::proxystub::CSnapshotOperationStub].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to invoke method [1] in class [lpbcorelib::interaction::ISnapshotOperation].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |An exception was thrown from thread [140310290929408].
[18.01.2018 15:37:38] <140310290929408> lpbcore| ERR |Failed to execute thaw script with status: fail.
[18.01.2018 15:37:38] <140310290929408> vmb    |     [SessionLog][error] Failed to create volume snapshot.
[18.01.2018 15:37:38] <140310290929408> lpbcore|   Taking snapshot. Failed.
[18.01.2018 15:37:38] <140310290929408> lpbcore| BackupJobPerformer: Creating backup. Failed.
[18.01.2018 15:37:38] <140310290929408> vmb    | [SessionLog][error] Failed to perform backup.
[18.01.2018 15:37:38] <140310290929408> vmb    | [SessionLog][error] Child execution has failed. Exit code: [1].
[18.01.2018 15:37:38] <140310290929408> vmb    | [SessionLog][error] Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0].
[18.01.2018 15:37:38] <140310290929408> vmb    | [SessionLog][error] Processing finished with errors at 2018-01-18 15:37:38 CET.
[18.01.2018 15:37:38] <140310290929408> lpbcore| ERR |Child execution has failed. Exit code: [1].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to execute [modprobe].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |Failed to load module [veeamsnap] with parameters [zerosnapdata=1 debuglogging=0].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to finish snapshot creation process.
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to execute method [1] for class [lpbcorelib::interaction::proxystub::CSnapshotOperationStub].
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |--tr:Failed to create volume snapshot.
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |Backup job has failed.
[18.01.2018 15:37:38] <140310290929408> lpbcore| >>  |An exception was thrown from thread [140310290929408].
[18.01.2018 15:37:38] <140310336378752>        |   Closing socket device.
[18.01.2018 15:37:38] <140310336378752> lpbcore| LpbManSession: Processing commands. ok.
[18.01.2018 15:37:38] <140310336378752>        | Closing socket device.
[18.01.2018 15:37:38] <140310290929408> lpbcore| JOB STATUS: FAILED.

Die Lösung bekam ich dazu aus dem Veeam Forum, wo ich mich mit dem Problem hinwandte.

Das Problem war, das die „Linux-Headers“ fehlten und somit das Modul nicht genutzt werden konnte. Eine nachinstallation dieser löste das Problem (in einer Shell mit Root-Rechten oder mit sudo):

apt-get install linux-headers-$(uname -r)
apt-get remove veeam
apt-get install veeam

Nun läuft die Sicherung:

Quelle: https://forums.veeam.com/veeam-agent-for-linux-f41/backup-failed-failed-to-create-snapshot-t48163.html


Windows Server: Es sind keine Anmeldeserver verfügbar

Ich habe nun schon einige Kunden, wo irgendwann nach einem Neustart das anmelden nicht möglich ist, statt dessen erscheint die Meldung: „Es sind keine Anmeldeserver verfügbar“.

Die Server sind Windows 2008 R2 bzw. SBS 2011 und Windows 2012 (R2) Server.

Bei den meisten Fällen war es nun so, das sich (warum auch immer) der Active-Directory-Recovery Modus aktiviert hat.

Das Problem lässt sich wie folgt beheben:

  • Startet den Server.
  • Wählt euch mit dem Active Directory Restore Benutzer und Kennwort an (.\administrator und entsprechendes Kennwort).
  • Sollte die GUI nicht komplett gestartet werden, drückt STRG+ALT+ENTF und wählt Taskmanager starten. Anschließend dann auf ausführen und MSCONFIG eingeben, gefolgt von einem Enter.
  • Sollte die GUI starten, geht auf Start > Ausführen und gebt MSCONFIG ein, gefolgt von einem Enter.
  • Geht zu dem Register Start und entfernt den Hacken bei Abgesicherter Start und speichert alles mit Ok.
  • Startet den Server neu.
  • Achtet bei dem Anmelden darauf, das ihr das richtige Konto nehmt für die Anmeldung (es ist noch Administrator voreingestellt).

Windows 10 auf Macbook Pro Retina 2015

Ich habe Windows 10 mit Bootcamp auf meinem Macbook Pro Retina 13″ Modell 2015 installiert. Nach der Windowsinstallation wird automatisch das Bootcamp Setup ausgeführt.

Leider hängt das bei mir (und auch vielen anderen) während des Punktes Realtek Audio.

Recherchen ergaben, das auch andere das Problem hatten und einfach im Taskmanager den Punkt Realtek Setup beendet haben. Danach lief dann die Installation weiter.

 

Quelle: https://discussions.apple.com/thread/6567790?tstart=0


Sicherungslösungen

Folgende Sicherungsmöglichkeiten gibt es:

Windows: Robocopy

Exchange: new-mailboxexportrequest

WHS: Acronis (Clientversion)

ESXI:

Kostenlos ohne Backup API: GhettoVCB: http://www.magikmon.com/mksbackup/ghettovcb.en.html

Mit Backup API: Veem

Hyper-V:

 

Kostenlos bis zu 2 VMs: http://go.altaro.com/?lang=de&LP=GppcHyper-V-RMR-Windowspro-DE&gclid=CKys6Y6shMICFczMtAodXEEAJw


Windows Produktkey auslesen (auf Offline und Server!)

Wenn ein Server so sehr beschädigt ist, das er nicht mehr startet und auch der Produktkey nicht auffindbar ist, dann kann mit dem Tool Produkey diesen auslesen, wenn man die Datei C:\Windows\System32\config\Software hat.

Dazu einfach das tool wie folgt starten:

produkey /regfile dateiname

Damit lassen sich natürlich auch aus laufenden Systemen der Produktkey auslesen.

 

Link: http://www.nirsoft.net/utils/product_cd_key_viewer.html


Windows 2012 R2 und Exchange 2013 SP1

Mal wieder Zeit mit aktuellen Produkten eine aktuelle Umgebung bereitzustellen.

Da der Windows Server 2012 R2 und das Exchange 2013 SP1 draußen ist, werfe ich mal einen Blick drauf und setze den bei mir im LAB ein.

Mal sehen, was es so neues gibt :).